Printing HP Deskjet 1000

I was having trouble printing to my HP Deskjet 1000. When printing a test page, the print job would appear to work, without any error message in /var/log/cups/error_log . however, nothing would print from the printer.

Turned out to be a simple solution, I had to install hplip and hpijs

yum install hplip hpijs

apt-get install hplip hpijs

With more recent versions of Ubuntu (and likely Debian), hpijs is now printer-driver-hpijs

apt-get install hplip printer-driver-hpijs

Odd that the (graphical) system configuration tool did not suggest installing those drivers.

This entry was posted in Fedora, Linux. Bookmark the permalink.

4 Responses to Printing HP Deskjet 1000

  1. I have this same problem with an HP LaserJet 1020p, and this is definitely the solution — using hplip.

    I have to periodically re-install the printer with the HP utility, as the system tends to “forget” about the printer (which, truthfully, I don’t use often enough to detect a pattern, whether it be kernel updates, CUPS updates or other).

  2. Tim Waugh says:

    The way to get these packages installed on demand automatically is to file a bug report to make sure the Device IDs get tagged into them.

    In this case, file a bug report against hplip, including the output of “lpinfo -v -l”.

    http://fedoraproject.org/wiki/Features/AutomaticPrintDriverInstallation

  3. Daniel Kaupp says:

    Hi,

    though this is totally unrelated to this topic, i don’t see a possibility to contact you directly concerning your NIDS with psad and fwsnort tutorial.

    I’m on Ubuntu 12.04 and i had configured ufw before.
    When I added the suggested Line: -A ufw-before-input -j LOG –log-level warn (btw, is the M at the end of the line above a typo?) and tried to restart ufw, it reads “ERROR: problem running ufw-init”, also it takes like forever ’til the prompt returns.

    Do you have a hint, on how i can track the error down further?

    Kind regards, Daniel

  4. bodhi.zazen says:

    @Daniel Kaupp – Yes the “M” is a typo, I will fix it asap. The line “-A ufw-before-input -j LOG –log-level warn” should already exist. You want to add 2 lines ABOVE that line.

    If you are having a problem , post your changes to the /etc/ufw/before.rules

Add Comment Register



Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>